Client mode setup for althea routers

Setting up an althea router in client mode is useful when one doesn’t have access to an ethernet cable to plug in to the gateway/internet port.

Configs

Here are the configs for files under /etc/

config/network

  • Add a new interface. For example, wlan5 after the backhaul interface.

    config interface 'wifi_backhaul'
             option ifname 'wlan5'
             option proto 'dhcp'
    

config/wireless

  • Remove every interface that includes mesh.

  • You only one of the wifi-device to connect. So for simplicity I only used one device.

  • Check the channel number of the network you want to connect to.

  • Example config:

    config wifi-device 'radio1'
      option type 'mac80211'
       # Channel number must be the same
      option channel '44'
      option hwmode '11a'
      option path 'platform/soc/a800000.wifi'
      option htmode 'VHT80'
      option disabled '0'
    
    config wifi-iface 'default_radio1'
      option device 'radio1'
       # new network defined in network config
      option network 'wifi_backhaul'
      option mode 'sta'
      # Name of the wifi network you want to connect to
      option ssid 'Status'
      # passprhase of the above network
      option key 'cryptolife'
       # make sure this matches the wifi you are attempting to connect to
      option encryption 'psk2+tkip+aes'
       # new interface name defined in network config
      option ifname 'wlan5'
    

information about encryption mode

config/firewall

  • Add the following config zone to firewall.

    config zone
       option     name       wifi_backhaul
       list       network   'wifi_backhaul'
       option     input      REJECT
       option     output     ACCEPT
       option     forward    REJECT
    

/etc/rita.toml

  • Change the old backhaul interface to wlan5.

    network.external_nic = “wlan5”

Restart the services

now restart the services with
wifi restart
service network restart
not sure if restarting rita is necessary but just leaving it here for future debate.
service rita restart

Basic trouble shooting

If your wlan5 does not get a dhcp lease from the network then something is wrong with the config in /etc/wireless/. The network config should be fine… since it is a really easy config.

If you do get a dhcp lease but you still don’t have internet then check the firewall and rita.toml configs.

2 Likes